Atari install issues

Post Reply
A173142
Posts: 2
Joined: Mon Mar 16, 2020 5:49 pm

Atari install issues

Post by A173142 » Tue Mar 17, 2020 8:18 am

I'd appreciate any help with the following issue while creating the course environment

I have tested the environment setup to the point of installing Atari and trying to run dqn.py

However when I run dqn_tf.py via ipython it fails

• Can’t find the directory ….rl2/Atari - which I can see via explorer in the same directory as .ipython,.jupyter etc


I then tried with Jupyter notebooks but that failed with some tensorflow version conflict between scipy using incompatible versions

• from scipy.misc import imresize
• tf.variable_scope


Thanks

lazyprogrammer
Site Admin
Posts: 18
Joined: Sat Jul 28, 2018 3:46 am

Re: Atari install issues

Post by lazyprogrammer » Wed Mar 18, 2020 1:51 pm

Thanks for your question!

Have you cloned the repository using "git clone" as described in the lectures?

Note that this course came out many years before Tensorflow 2 came out, so it's recommended that you create a virtual environment for installing Tensorflow 1.

You can replace scipy's imresize with https://scikit-image.org/docs/dev/api/s ... orm.resize

Post Reply

Return to “Deep Learning Prerequisites: The Numpy Stack in Python”